Страница 45 из 46

Re: 1887ВЕ4У

Добавлено: 18 июн 2018, 12:57
sya
nppsem писал(а):
18 июн 2018, 12:30
1 Можно озвучить типовой диапазон значений для сопротивления I/O Pin Pull-up Resistor? Перерыл ТО и форум, не нашёл.
2 Понятно, что наличие тока через защитные диоды на входах портов не допускается. Однако, Atmel (до своего поглощения) для функционального аналога допускал (сквозь зубы :mrgreen:) ±1 мА. Можно, как справочный параметр (или даже в ЛС), узнать порядок "безопасного" тока через защитные диоды?
Здравствуйте!
Типовое значение сопротивления подтягивающего резистора вывода I/O составляет 30 кОм.

Re: 1887ВЕ4У

Добавлено: 18 июн 2018, 14:27
nppsem
Спасибо, принято!

1887ВЕ4У

Добавлено: 22 авг 2018, 16:51
Палыч
1. Ошибка в тексте ТО
a) Пункты 3.4.3. и 3.4.4: При описании режимов микропотребления и хранения неверно указаны соответствующие английские названия режимов. Таблица 3.14: Строки таблицы с указанными выше режимами - перепутаны.
б) Как я понял из обсуждений на форуме: память программ - это не флэш-память. Почему обратное утверждается в ТО ?

2. Хотелось бы всё же увидеть некий документ - сборник выявленных/устранённых ошибок наподобие Errata. В частности меня интересует: как обстоят дела с выявленной три года назад ошибкой при записи в память данных ЭСППЗУ ?

1887ВЕ4У

Добавлено: 24 авг 2018, 17:22
Палыч
Ошибка в тексте ТО:
В п.3.15.4 на стр.148 приведены примеры кода. В примерах запись в регистр UCSRC производится без единицы в бите URSEL.

Re: 1887ВЕ4У

Добавлено: 03 сен 2018, 14:02
sya
Здравствуйте!

1. Спасибо за замечания об ошибках в ТО.
2. Ошибка исправлена.

Re: 1887ВЕ4У

Добавлено: 11 окт 2018, 18:05
Gusev
Добрый день.
Относительно недавно приобрели у вас несколько микроконтроллеров 1887ВЕ4У. Установили в опытный образец, при эксплуатации в нормальных условиях вышли из строя 2 микроконтроллера, не сразу, последовательно с разницей в месяц.
Первый не реагировал ни на что, второй отвечал программатору. Считали код программы, получили некую повторяющуюся последовательность. Фьюзы также были установлены не так как их программировали мы. ID не соответствовал данному микроконтроллеру.

На другом опытном образце эксплуатация штатная. Помогите объяснить что могло случиться, особенно в случае со вторым контроллером.

Re: 1887ВЕ4У

Добавлено: 12 окт 2018, 12:31
Anton_LEMZ
Здравствуйте! Возникла проблема после замены контроллера на сборочной единице. Было изготовлено две одинаковые ячейки, обе содержат кварцевый резонатор на 8 МГц обе программировались через программатор AVRISP mkII и проблем не было. Затем в процессе эксплуатации одной из ячеек вышла из строя ножка АЦП контроллера (эксплуатационный дефект), после замены микроконтроллера на новый с маркировкой 1407 контроллер перестал шиться. Проверил осциллографом, все сигналы до него доходят а с контроллера по 9 выводу (MISO) ничего нет, при этом вторая аналогичная ячейка полностью функционирует и прошивается этим же программатором. Пробовал затактировать на 15 вывод (BQ1) принудительно от внешнего источника сигнала (2 МГц) и не помогло. Предположил, что контроллер бракованный, на макетную плату распаял еще один из этой же партии на аналогичную схему обвязки и он ведет себя точно так же, сигнала по выходу MISO нет. В чем может быть причина? Спасибо!

Re: 1887ВЕ4У

Добавлено: 15 окт 2018, 09:55
sya
Здравствуйте, Anton_LEMZ, Gusev!

По вашим описаниям сложно сказать, в чем может быть проблема. Присылайте схемы нам на анализ.

Re: 1887ВЕ4У

Добавлено: 08 ноя 2018, 17:42
OlegMagn
Добрый день.
Пытаюсь записать прошивку в 1887ВЕ4У. Использую программатор STK500-V2 с программой avrdude,
процессор ставлю atmega8535. Фьюзы выставил на кварц 16мгц.
Не пишутся первые 400 байт (0x190), все нули, остальные данные совпадают.
Пробовал также USBASP с avrdude и с Khazama, эффект тотже. EEPROM пишется правильно.
В чем может быть проблема ?

Спасибо.
Олег.

Re: 1887ВЕ4У

Добавлено: 12 ноя 2018, 12:43
avp
OlegMagn писал(а):
08 ноя 2018, 17:42
Добрый день.
Пытаюсь записать прошивку в 1887ВЕ4У. Использую программатор STK500-V2 с программой avrdude,
процессор ставлю atmega8535. Фьюзы выставил на кварц 16мгц.
Не пишутся первые 400 байт (0x190), все нули, остальные данные совпадают.
Пробовал также USBASP с avrdude и с Khazama, эффект тотже. EEPROM пишется правильно.
В чем может быть проблема ?

Спасибо.
Олег.
Здравствуйте.
Возможно, перед записью данных идет процедура ChipErase. Стирание кристалла необходимо выполнять отдельно, т.к. длительность цикла стирания в нашем случаи больше.