1874ВЕ7Т

Модераторы: gurzzza, pip, _sva_

sazonovsv
Сообщения: 51
Зарегистрирован: 02 сен 2014, 15:35

Подключение эмулятора через UART-1

Сообщение sazonovsv » 28 фев 2018, 17:27

Используется процессор 1874ВЕ7Т (дата изготовления 1543). Тактовая частота=24МГц.
Эмулятор JEM-96 (SN: JEM-96-OCD 10-046).
Сам процессор УСПЕШНО работает под управлением разных программ записанных во внешнюю флэш-память.
Однако попытка подключится в режим отладки через эмулятор в режиме debug Monitor-UART1 вызывает ошибку уже на шаге выбора эмулятора (в среде CodeMaster-96 окно «Выбор эмулятора» -> «Эмулятор JEM-96»).

Вариант 1:
Вариант подключения: UART-1; Для выбора режима эмулятора используется порт P2.2 подключенный к сигналу DBG/. Остальные подключения согласно руководству к эмулятору JEM-96. Сигналы Р0.4 и Р0.5 притянуты к «лог.1» (2.4В).
Вариант компиляции программы: Программа для прогона под отладчиком УСПЕШНО откомпилирована с учетом опции «1874ВЕ7Т rev.2 with debug monitor-UART1» и записана во внешнюю флэш-память.
Тип ошибки: Аппаратная ошибка #0x0205

Вариант 1:
Вариант подключения: UART-1; Для выбора режима эмулятора используется порт P0.6 подключенный к сигналу DBG/. Остальные подключения согласно руководству к эмулятору JEM-96. Сигналы Р0.4 и Р0.5 притянуты к «лог.1» (2.4В).
Вариант компиляции программы: Программа для прогона под отладчиком УСПЕШНО откомпилирована с учетом опции «1874ВЕ71Т rev.2 with debug monitor-PORT0» и записана во внешнюю флэш-память.
Тип ошибки: Аппаратная ошибка #0x0205

Отчет о сбое(вариант 1) прикреплен к сообщению.

НЕ работают оба варианта!!!
Как исправить эту ситуацию??????
Как проверить, что отладочный монитор прилинковался к основной программе ?

sazonovsv
Сообщения: 51
Зарегистрирован: 02 сен 2014, 15:35

Подключение эмулятора через UART-1 (дополнение)

Сообщение sazonovsv » 28 фев 2018, 17:34

почему то не прикрепился отчет о сбое к предыдущему сообщению
Прикрепляю....

sazonovsv
Сообщения: 51
Зарегистрирован: 02 сен 2014, 15:35

Re: Подключение эмулятора через UART-1 (дополнение)

Сообщение sazonovsv » 28 фев 2018, 17:59

sazonovsv писал(а):
28 фев 2018, 17:34
почему то не прикрепился отчет о сбое к предыдущему сообщению
Прикрепляю....
Вложения
CM-96_Bug_Report(H).zip
(104.48 КБ) 16 скачиваний

sazonovsv
Сообщения: 51
Зарегистрирован: 02 сен 2014, 15:35

Re: Подключение эмулятора через UART-1

Сообщение sazonovsv » 05 мар 2018, 18:47

Добрый день, коллеги!
Прошу прощения, 3 моих предыдущих сообщения о невозможности подключения эмулятора JEM-96 к МК 1874ВЕ7Т через UART-1 нужно считать неактуальными!
Обнаружилась ошибка-перелом проводка в кабеле эмулятора. Теперь всё работает!
Если возможно, то удалите 3 моих предыдущих сообщения, чтобы не вводить читателей в непонимание.

Еще раз извините))))

abval
Сообщения: 1
Зарегистрирован: 27 мар 2018, 18:14
Предприятие: ИКИ РАН

Re: 1874ВЕ7Т АЦП

Сообщение abval » 27 мар 2018, 18:27

Добрый день!
Можете подсказать какое входное сопротивление у АЦП 1874ВЕ7Т?

Ответить

Вернуться в «Микроконтроллер 1874ВЕ7Т»

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и 1 гость